{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2016-3088 in the wild since at least 10 Feb 2022.","fix":"Upgrade org.apache.activemq:activemq-client to 5.14.0 or later. US federal agencies must fix it by 10 Aug 2022.","what":"CVE-2016-3088 is a critical vulnerability in Apache Activemq, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3088 and fix it if it is affected.\n\nWhat it is: CVE-2016-3088 is a critical vulnerability in Apache Activemq, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2016-3088 in the wild since at least 10 Feb 2022.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.14.0\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3088/ (Markdown: https://insights.sbomify.com/CVE-2016-3088/index.md)","id":"CVE-2016-3088","markdown":"https://insights.sbomify.com/CVE-2016-3088/index.md","name":"CVE-2016-3088","record":{"aliases":["DEBIAN-CVE-2016-3088","GHSA-rxqh-fc23-gxp2","UBUNTU-CVE-2016-3088"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Remote attackers can upload and execute arbitrary files in Apache ActiveMQ Fileserver via HTTP PUT and MOVE requests.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.","ecosystems":["Maven"],"exploits":{"exploitdb":2,"first_seen":"2015-08-17","github_poc":9,"max_poc_stars":86,"metasploit":1,"nuclei":1,"refs":[{"date":"2026-04-20T02:38:50Z","kind":"github_poc","ref":"https://github.com/Catherines77/ActiveMQ-EXPtools","stars":86,"title":"Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588)"},{"date":"2022-04-02T08:40:10Z","kind":"github_poc","ref":"https://github.com/YutuSec/ActiveMQ_Crack","stars":18,"title":"ActiveMQ系列漏洞探测利用工具，包括ActiveMQ 默认口令漏洞及ActiveMQ任意文件写入漏洞（CVE-2016-3088），支持批量探测利用。"},{"date":"2020-07-31T09:06:15Z","kind":"github_poc","ref":"https://github.com/Ma1Dong/ActiveMQ_putshell-CVE-2016-3088","stars":15,"title":"ActiveMQ_putshell直接获取webshell"},{"date":"2021-03-11T05:54:34Z","kind":"github_poc","ref":"https://github.com/cyberaguiar/CVE-2016-3088","stars":5,"title":"Apache ActiveMQ Remote Code Execution Exploit"},{"date":"2021-07-03T10:23:59Z","kind":"github_poc","ref":"https://github.com/cl4ym0re/CVE-2016-3088","stars":4,"title":"Apache ActiveMQ PUT RCE Scan"},{"date":"2015-08-17","kind":"exploitdb","ref":"40857","stars":null,"title":"Apache ActiveMQ 5.11.1/5.13.2 - Directory Traversal / Command Execution"},{"date":"2016-06-01","kind":"metasploit","ref":"exploit/multi/http/apache_activemq_upload_jsp","stars":null,"title":"ActiveMQ web shell upload"},{"date":"2017-06-29","kind":"exploitdb","ref":"42283","stars":null,"title":"ActiveMQ \u003c 5.14.0 - Web Shell Upload (Metasploit)"}],"tier":"exploited"},"has_fix":true,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","indexable":true,"kev":{"dateAdded":"2022-02-10","dueDate":"2022-08-10","knownRansomwareCampaignUse":"Unknown","product":"ActiveMQ","requiredAction":"Apply updates per vendor instructions.","vendorProject":"Apache","vulnerabilityName":"Apache ActiveMQ Improper Input Validation Vulnerability"},"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq"],"type":"file_upload","year":"2016"},"n_packages":2,"n_references":9,"next":{"headline":"Apache OpenMeetings Cross-site Scripting vulnerability","id":"CVE-2016-3089"},"packages":[{"ecosystem":"Maven","fixed":["5.14.0"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-rxqh-fc23-gxp2"},{"ecosystem":"Maven","fixed":["5.14.0"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-rxqh-fc23-gxp2"}],"prev":{"headline":"Apache Struts vulnerable to arbitrary remote code execution due to improper input validation","id":"CVE-2016-3087"},"products":["n/a"],"published":"2016-06-01","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["n/a"]},"summary":"Remote attackers can upload and execute arbitrary files in Apache ActiveMQ Fileserver via HTTP PUT and MOVE requests.","url":"https://insights.sbomify.com/CVE-2016-3088/"}