# CVE-2016-3088: Apache ActiveMQ Improper Input Validation

> Remote attackers can upload and execute arbitrary files in Apache ActiveMQ Fileserver via HTTP PUT and MOVE requests.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 10 Feb 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2016
- **Updated:** 21 Oct 2025
- **Also known as:** DEBIAN-CVE-2016-3088, GHSA-rxqh-fc23-gxp2, UBUNTU-CVE-2016-3088

## What is CVE-2016-3088?

CVE-2016-3088 is a critical vulnerability in Apache Activemq, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2016-3088?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.14.0 |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.14.0 |

Products: Apache Activemq.

## How do I fix CVE-2016-3088?

Upgrade org.apache.activemq:activemq-client to 5.14.0 or later. US federal agencies must fix it by 10 Aug 2022.

## Is CVE-2016-3088 being exploited?

Yes. Attackers have exploited CVE-2016-3088 in the wild since at least 10 Feb 2022.

Public exploit code:

- Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588) (github_poc): https://github.com/Catherines77/ActiveMQ-EXPtools
- ActiveMQ系列漏洞探测利用工具，包括ActiveMQ 默认口令漏洞及ActiveMQ任意文件写入漏洞（CVE-2016-3088），支持批量探测利用。 (github_poc): https://github.com/YutuSec/ActiveMQ_Crack
- ActiveMQ_putshell直接获取webshell (github_poc): https://github.com/Ma1Dong/ActiveMQ_putshell-CVE-2016-3088
- Apache ActiveMQ Remote Code Execution Exploit (github_poc): https://github.com/cyberaguiar/CVE-2016-3088
- Apache ActiveMQ PUT RCE Scan (github_poc): https://github.com/cl4ym0re/CVE-2016-3088
- Apache ActiveMQ 5.11.1/5.13.2 - Directory Traversal / Command Execution (exploitdb)

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)
- [CVE-2014-3600](https://insights.sbomify.com/CVE-2014-3600/): Improper Restriction of XML External Entity Reference in Apache ActiveMQ (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3088 and fix it if it is affected.

What it is: CVE-2016-3088 is a critical vulnerability in Apache Activemq, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2016-3088 in the wild since at least 10 Feb 2022.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.14.0
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3088/ (Markdown: https://insights.sbomify.com/CVE-2016-3088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3088
- OSV: https://osv.dev/vulnerability/CVE-2016-3088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3088/
Summaries are generated and may contain mistakes; the official description above is the record.
