# CVE-2016-3094: Improper Input Validation in org.apache.qpid:qpid-broker

> Remote attackers can cause broker termination via crafted authentication attempts when plaintext passwords are enabled in Apache Qpid Java.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jj9h-mwhq-8vhm, UBUNTU-CVE-2016-3094

## What is CVE-2016-3094?

CVE-2016-3094 is a medium-severity denial of service vulnerability in n/a, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PlainSaslServer.java in Apache Qpid Java before 6.0.3, when the broker is configured to allow plaintext passwords, allows remote attackers to cause a denial of service (broker termination) via a crafted authentication attempt, which triggers an uncaught exception.

Weakness: CWE-287 (Improper Authentication), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-3094?

2 open source packages ship an affected version, including org.apache.qpid:qpid-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:qpid-broker` | Maven | All versions | 6.0.3 |
| `org.apache.qpid:qpid-broker` | Maven | All versions | 6.0.3 |

Products: Apache Qpid Broker-J.

## How do I fix CVE-2016-3094?

Upgrade org.apache.qpid:qpid-broker to 6.0.3 or later.

## Is CVE-2016-3094 being exploited?

There is no known exploitation of CVE-2016-3094 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-92609](https://insights.sbomify.com/CVE-2026-92609/): Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication (critical 9.8)
- [CVE-2017-15702](https://insights.sbomify.com/CVE-2017-15702/): Apache Qpid Broker vulnerable to authentication port spoofing (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3094 and fix it if it is affected.

What it is: CVE-2016-3094 is a medium-severity denial of service vulnerability in n/a, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3094 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:qpid-broker (Maven): affected all versions; fixed in 6.0.3
- org.apache.qpid:qpid-broker (Maven): affected all versions; fixed in 6.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3094/ (Markdown: https://insights.sbomify.com/CVE-2016-3094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3094
- OSV: https://osv.dev/vulnerability/CVE-2016-3094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3094/
Summaries are generated and may contain mistakes; the official description above is the record.
