{"answers":{"affected":"5 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-3096 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 1.9.6.1 or 2.0.2.0.","what":"CVE-2016-3096 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 3 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3096 and fix it if it is affected.\n\nWhat it is: CVE-2016-3096 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 3 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3096 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 1.9.6.1\n- ansible (PyPI): affected all versions; fixed in 1.9.6.1\n- ansible (PyPI): affected all versions; fixed in 2.0.2.0\n- ansible (PyPI): affected from 2.0.0.0; fixed in 2.0.2.0\n- ansible (PyPI): affected from 2.0.0.0; fixed in 2.0.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3096/ (Markdown: https://insights.sbomify.com/CVE-2016-3096/index.md)","id":"CVE-2016-3096","markdown":"https://insights.sbomify.com/CVE-2016-3096/index.md","name":"CVE-2016-3096","record":{"aliases":["DEBIAN-CVE-2016-3096","GHSA-rh6x-qvg7-rrmj","MGASA-2016-0163","PYSEC-2016-1","UBUNTU-CVE-2016-3096"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible LXC module","requires_auth":"low_privilege","summary":"Local attackers can exploit symlink vulnerabilities in Ansible's LXC module to write arbitrary files or escalate privileges.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ansible","vendor":"redhat"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /opt/.lxc-attach-script, (2) the archived container in the archive_path directory, or the (3) lxc-attach-script.log or (4) lxc-attach-script.err files in the temporary directory.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Link Following in ansible","id":"CVE-2016-3096","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"path_traversal","year":"2016"},"n_packages":5,"n_references":13,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-3097"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.6.1"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-rh6x-qvg7-rrmj"},{"ecosystem":"PyPI","fixed":["1.9.6.1"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-rh6x-qvg7-rrmj"},{"ecosystem":"PyPI","fixed":["2.0.2.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2016-1"},{"ecosystem":"PyPI","fixed":["2.0.2.0"],"introduced":["2.0.0.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-rh6x-qvg7-rrmj"},{"ecosystem":"PyPI","fixed":["2.0.2.0"],"introduced":["2.0.0.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-rh6x-qvg7-rrmj"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-3095"},"products":["n/a"],"published":"2016-06-03","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Local attackers can exploit symlink vulnerabilities in Ansible's LXC module to write arbitrary files or escalate privileges.","url":"https://insights.sbomify.com/CVE-2016-3096/"}