# CVE-2016-3096: Link Following in ansible

> Local attackers can exploit symlink vulnerabilities in Ansible's LXC module to write arbitrary files or escalate privileges.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-3096, GHSA-rh6x-qvg7-rrmj, MGASA-2016-0163, PYSEC-2016-1, UBUNTU-CVE-2016-3096

## What is CVE-2016-3096?

CVE-2016-3096 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 3 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /opt/.lxc-attach-script, (2) the archived container in the archive_path directory, or the (3) lxc-attach-script.log or (4) lxc-attach-script.err files in the temporary directory.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2016-3096?

5 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.9.6.1 |
| `ansible` | PyPI | All versions | 1.9.6.1 |
| `ansible` | PyPI | All versions | 2.0.2.0 |
| `ansible` | PyPI | From 2.0.0.0 | 2.0.2.0 |
| `ansible` | PyPI | From 2.0.0.0 | 2.0.2.0 |

Products: Fedoraproject Fedora, Redhat Ansible.

## How do I fix CVE-2016-3096?

Upgrade ansible to a fixed version for your release line: 1.9.6.1 or 2.0.2.0.

## Is CVE-2016-3096 being exploited?

There is no known exploitation of CVE-2016-3096 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3096 and fix it if it is affected.

What it is: CVE-2016-3096 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 3 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3096 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.9.6.1
- ansible (PyPI): affected all versions; fixed in 1.9.6.1
- ansible (PyPI): affected all versions; fixed in 2.0.2.0
- ansible (PyPI): affected from 2.0.0.0; fixed in 2.0.2.0
- ansible (PyPI): affected from 2.0.0.0; fixed in 2.0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3096/ (Markdown: https://insights.sbomify.com/CVE-2016-3096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3096
- OSV: https://osv.dev/vulnerability/CVE-2016-3096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3096/
Summaries are generated and may contain mistakes; the official description above is the record.
