{"answers":{"affected":"2 open source packages ship an affected version, including administrate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-3098 in the wild and no public exploit code.","fix":"Upgrade administrate to 0.1.5 or later.","what":"CVE-2016-3098 is a medium-severity vulnerability in administrate, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-3098 and fix it if it is affected.\n\nWhat it is: CVE-2016-3098 is a medium-severity vulnerability in administrate, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-3098 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- administrate (RubyGems): affected all versions; fixed in 0.1.5\n- administrate (RubyGems): affected all versions; fixed in 0.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3098/ (Markdown: https://insights.sbomify.com/CVE-2016-3098/index.md)","id":"CVE-2016-3098","markdown":"https://insights.sbomify.com/CVE-2016-3098/index.md","name":"CVE-2016-3098","record":{"aliases":["GHSA-cc8c-26rj-v2vx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby admin framework","requires_auth":"none","summary":"Attackers can hijack user OAuth authorization codes via CSRF in the administrate Ruby library, potentially leading to account takeover.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"administrate","vendor":"thoughtbot"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-site request forgery (CSRF) vulnerability in administrate 0.1.4 and earlier allows remote attackers to hijack the user's OAuth autorization code.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"administrate vulnerable to Cross-Site Request Forgery","id":"CVE-2016-3098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2016-3099"},"packages":[{"ecosystem":"RubyGems","fixed":["0.1.5"],"introduced":["0"],"last_affected":[],"package":"administrate","purl":null,"source":"GHSA-cc8c-26rj-v2vx"},{"ecosystem":"RubyGems","fixed":["0.1.5"],"introduced":["0"],"last_affected":[],"package":"administrate","purl":"pkg:gem/administrate","source":"GHSA-cc8c-26rj-v2vx"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-3097"},"products":["administrate"],"published":"2022-08-05","related":[{"cvss_score":7.7,"headline":"Sort order SQL injection in Administrate","id":"CVE-2020-5257","kev_date_added":null,"published":"2020-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can hijack user OAuth authorization codes via CSRF in the administrate Ruby library, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2016-3098/"}