{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:extra-columns. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-3101 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:extra-columns to 1.17 or later.","what":"CVE-2016-3101 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-3101 and fix it if it is affected.\n\nWhat it is: CVE-2016-3101 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-3101 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:extra-columns (Maven): affected all versions; fixed in 1.17\n- org.jenkins-ci.plugins:extra-columns (Maven): affected all versions; fixed in 1.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3101/ (Markdown: https://insights.sbomify.com/CVE-2016-3101/index.md)","id":"CVE-2016-3101","markdown":"https://insights.sbomify.com/CVE-2016-3101/index.md","name":"CVE-2016-3101","record":{"aliases":["GHSA-mr4j-7jjv-24m7"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via unfiltered tool tips in the Jenkins Extra Columns plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"extra_columns","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the Extra Columns plugin before 1.17 in Jenkins allows remote attackers to inject arbitrary web script or HTML by leveraging failure to filter tool tips through the configured markup formatter.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Extra Columns Plugin allows Cross-Site Scripting (XSS)","id":"CVE-2016-3101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Script Security Plugin allows for Bypass of Groovy Sandbox Protection","id":"CVE-2016-3102"},"packages":[{"ecosystem":"Maven","fixed":["1.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:extra-columns","purl":null,"source":"GHSA-mr4j-7jjv-24m7"},{"ecosystem":"Maven","fixed":["1.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:extra-columns","purl":"pkg:maven/org.jenkins-ci.plugins/extra-columns","source":"GHSA-mr4j-7jjv-24m7"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-3100"},"products":["n/a"],"published":"2017-02-09","related":[{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins Extra Columns Plugin","id":"CVE-2021-21630","kev_date_added":null,"published":"2021-03-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via unfiltered tool tips in the Jenkins Extra Columns plugin.","url":"https://insights.sbomify.com/CVE-2016-3101/"}