# CVE-2016-3101: Jenkins Extra Columns Plugin allows Cross-Site Scripting (XSS)

> Remote attackers can inject arbitrary web script or HTML via unfiltered tool tips in the Jenkins Extra Columns plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mr4j-7jjv-24m7

## What is CVE-2016-3101?

CVE-2016-3101 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Extra Columns plugin before 1.17 in Jenkins allows remote attackers to inject arbitrary web script or HTML by leveraging failure to filter tool tips through the configured markup formatter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-3101?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:extra-columns. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:extra-columns` | Maven | All versions | 1.17 |
| `org.jenkins-ci.plugins:extra-columns` | Maven | All versions | 1.17 |

Products: Jenkins Extra Columns.

## How do I fix CVE-2016-3101?

Upgrade org.jenkins-ci.plugins:extra-columns to 1.17 or later.

## Is CVE-2016-3101 being exploited?

There is no known exploitation of CVE-2016-3101 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21630](https://insights.sbomify.com/CVE-2021-21630/): Stored XSS vulnerability in Jenkins Extra Columns Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3101 and fix it if it is affected.

What it is: CVE-2016-3101 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-3101 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:extra-columns (Maven): affected all versions; fixed in 1.17
- org.jenkins-ci.plugins:extra-columns (Maven): affected all versions; fixed in 1.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3101/ (Markdown: https://insights.sbomify.com/CVE-2016-3101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3101
- OSV: https://osv.dev/vulnerability/CVE-2016-3101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3101/
Summaries are generated and may contain mistakes; the official description above is the record.
