{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-3102 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:script-security to 1.18.1 or later.","what":"CVE-2016-3102 is a high-severity vulnerability in n/a, published on 9 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3102 and fix it if it is affected.\n\nWhat it is: CVE-2016-3102 is a high-severity vulnerability in n/a, published on 9 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3102 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.18.1\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3102/ (Markdown: https://insights.sbomify.com/CVE-2016-3102/index.md)","id":"CVE-2016-3102","markdown":"https://insights.sbomify.com/CVE-2016-3102/index.md","name":"CVE-2016-3102","record":{"aliases":["GHSA-xgjx-96v4-mqxx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Remote attackers can bypass Groovy sandbox protections in the Jenkins Script Security plugin to execute arbitrary code.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"script_security","vendor":"jenkins"}],"cvss":{"score":7.3,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-254","name":null}],"description":"The Script Security plugin before 1.18.1 in Jenkins might allow remote attackers to bypass a Groovy sandbox protection mechanism via a plugin that performs (1) direct field access or (2) get/set array operations.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Script Security Plugin allows for Bypass of Groovy Sandbox Protection","id":"CVE-2016-3102","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-3103"},"packages":[{"ecosystem":"Maven","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":null,"source":"GHSA-xgjx-96v4-mqxx"},{"ecosystem":"Maven","fixed":["1.18.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","source":"GHSA-xgjx-96v4-mqxx"}],"prev":{"headline":"Jenkins Extra Columns Plugin allows Cross-Site Scripting (XSS)","id":"CVE-2016-3101"},"products":["n/a"],"published":"2017-02-09","related":[{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin Sandbox Bypass","id":"CVE-2019-1003029","kev_date_added":"2022-04-25","published":"2019-03-08"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43401","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2022-43403","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43404","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerability in Jenkins Script Security Plugin","id":"CVE-2020-2279","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":9.9,"headline":"Improper Control of Generation of Code in Jenkins Script Security Plugin","id":"CVE-2019-10431","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":9.8,"headline":"Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies","id":"CVE-2024-34144","kev_date_added":null,"published":"2024-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass Groovy sandbox protections in the Jenkins Script Security plugin to execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2016-3102/"}