# CVE-2016-3102: Jenkins Script Security Plugin allows for Bypass of Groovy Sandbox Protection

> Remote attackers can bypass Groovy sandbox protections in the Jenkins Script Security plugin to execute arbitrary code.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xgjx-96v4-mqxx

## What is CVE-2016-3102?

CVE-2016-3102 is a high-severity vulnerability in n/a, published on 9 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Script Security plugin before 1.18.1 in Jenkins might allow remote attackers to bypass a Groovy sandbox protection mechanism via a plugin that performs (1) direct field access or (2) get/set array operations.

Weakness: CWE-254

## Which versions are affected by CVE-2016-3102?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.18.1 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.18.1 |

Products: Jenkins Script Security.

## How do I fix CVE-2016-3102?

Upgrade org.jenkins-ci.plugins:script-security to 1.18.1 or later.

## Is CVE-2016-3102 being exploited?

There is no known exploitation of CVE-2016-3102 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3102 and fix it if it is affected.

What it is: CVE-2016-3102 is a high-severity vulnerability in n/a, published on 9 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3102 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.18.1
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3102/ (Markdown: https://insights.sbomify.com/CVE-2016-3102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3102
- OSV: https://osv.dev/vulnerability/CVE-2016-3102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3102/
Summaries are generated and may contain mistakes; the official description above is the record.
