{"answers":{"affected":"3 open source packages ship an affected version, including mercurial. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-3105 in the wild and no public exploit code.","fix":"Upgrade mercurial to a fixed version for your release line: 3.8 or 3.8-rc.","what":"CVE-2016-3105 is a high-severity code injection vulnerability in Debian Debian Linux, published on 9 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-3105 and fix it if it is affected.\n\nWhat it is: CVE-2016-3105 is a high-severity code injection vulnerability in Debian Debian Linux, published on 9 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-3105 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mercurial (PyPI): affected all versions; fixed in 3.8\n- mercurial (PyPI): affected all versions; fixed in 3.8\n- mercurial (PyPI): affected all versions; fixed in 3.8-rc\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3105/ (Markdown: https://insights.sbomify.com/CVE-2016-3105/index.md)","id":"CVE-2016-3105","markdown":"https://insights.sbomify.com/CVE-2016-3105/index.md","name":"CVE-2016-3105","record":{"aliases":["DEBIAN-CVE-2016-3105","DLA-459-1","DSA-3570-1","GHSA-49cw-434h-qc57","MGASA-2016-0172","PYSEC-2016-28","SUSE-SU-2016:1442-1","SUSE-SU-2016:1443-1","UBUNTU-CVE-2016-3105"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mercurial SCM","requires_auth":"none","summary":"Attackers can execute arbitrary code via a crafted git repository name in the Mercurial convert extension.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mercurial","vendor":"mercurial"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.","ecosystems":["PyPI","SUSE:Linux Enterprise Software Development Kit 11 SP4","SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Software Development Kit 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mercurial vulnerable to arbitrary code execution when converting Git repos","id":"CVE-2016-3105","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"code_injection","year":"2016"},"n_packages":6,"n_references":7,"next":{"headline":"Race condition in n/a","id":"CVE-2016-3106"},"packages":[{"ecosystem":"PyPI","fixed":["3.8"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":null,"source":"GHSA-49cw-434h-qc57"},{"ecosystem":"PyPI","fixed":["3.8"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"GHSA-49cw-434h-qc57"},{"ecosystem":"PyPI","fixed":["3.8-rc"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"PYSEC-2016-28"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["2.3.2-0.14.2"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:rpm/suse/mercurial\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2016:1443-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["2.8.2-9.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:rpm/suse/mercurial\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2016:1442-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["2.8.2-9.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:rpm/suse/mercurial\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2016:1442-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-3104"},"products":["n/a"],"published":"2016-05-09","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via a crafted git repository name in the Mercurial convert extension.","url":"https://insights.sbomify.com/CVE-2016-3105/"}