# CVE-2016-3105: Mercurial vulnerable to arbitrary code execution when converting Git repos

> Attackers can execute arbitrary code via a crafted git repository name in the Mercurial convert extension.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-3105, DLA-459-1, DSA-3570-1, GHSA-49cw-434h-qc57, MGASA-2016-0172, PYSEC-2016-28, SUSE-SU-2016:1442-1, SUSE-SU-2016:1443-1, UBUNTU-CVE-2016-3105

## What is CVE-2016-3105?

CVE-2016-3105 is a high-severity code injection vulnerability in Debian Debian Linux, published on 9 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-3105?

3 open source packages ship an affected version, including mercurial. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 3.8 |
| `mercurial` | PyPI | All versions | 3.8 |
| `mercurial` | PyPI | All versions | 3.8-rc |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 2.3.2-0.14.2 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 | All versions | 2.8.2-9.1 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 SP1 | All versions | 2.8.2-9.1 |

Products: Debian Debian Linux, Mercurial Mercurial.

## How do I fix CVE-2016-3105?

Upgrade mercurial to a fixed version for your release line: 3.8 or 3.8-rc.

## Is CVE-2016-3105 being exploited?

There is no known exploitation of CVE-2016-3105 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3105 and fix it if it is affected.

What it is: CVE-2016-3105 is a high-severity code injection vulnerability in Debian Debian Linux, published on 9 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-3105 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 3.8
- mercurial (PyPI): affected all versions; fixed in 3.8
- mercurial (PyPI): affected all versions; fixed in 3.8-rc

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3105/ (Markdown: https://insights.sbomify.com/CVE-2016-3105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3105
- OSV: https://osv.dev/vulnerability/CVE-2016-3105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3105/
Summaries are generated and may contain mistakes; the official description above is the record.
