CVE-2016-3109 Shopware RCE Vulnerability
Remote attackers can execute arbitrary code via the backend login script in Shopware, requiring an upgrade to secure the e-commerce platform.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3109?
CVE-2016-3109 is a critical code injection vulnerability in Shopware Shopware, published on 21 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
Weakness: CWE-20
Which versions are affected by CVE-2016-3109?
4 open source packages ship an affected version, including shopware/shopware. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/shopware Packagist | All versions | 4.3.7 |
shopware/shopware Packagist | All versions | 4.3.7 |
shopware/shopware Packagist | From 5.0.0 | 5.1.5 |
shopware/shopware Packagist | From 5.0.0 | 5.1.5 |
Products include Shopware Shopware.
How do I fix CVE-2016-3109?
Upgrade shopware/shopware to a fixed version for your release line: 4.3.7 or 5.1.5.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2016-3109 being exploited?
There is no known exploitation of CVE-2016-3109 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
- CVE-2026-31889 Shopware has a potential take over of app credentials
Sources
Also known as GHSA-cj2f-96jq-phpp.