{"answers":{"affected":"4 open source packages ship an affected version, including shopware/shopware. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-3109 in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to a fixed version for your release line: 4.3.7 or 5.1.5.","what":"CVE-2016-3109 is a critical code injection vulnerability in Shopware Shopware, published on 21 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3109 and fix it if it is affected.\n\nWhat it is: CVE-2016-3109 is a critical code injection vulnerability in Shopware Shopware, published on 21 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3109 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected all versions; fixed in 4.3.7\n- shopware/shopware (Packagist): affected all versions; fixed in 4.3.7\n- shopware/shopware (Packagist): affected from 5.0.0; fixed in 5.1.5\n- shopware/shopware (Packagist): affected from 5.0.0; fixed in 5.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3109/ (Markdown: https://insights.sbomify.com/CVE-2016-3109/index.md)","id":"CVE-2016-3109","markdown":"https://insights.sbomify.com/CVE-2016-3109/index.md","name":"CVE-2016-3109","record":{"aliases":["GHSA-cj2f-96jq-phpp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via the backend login script in Shopware, requiring an upgrade to secure the e-commerce platform.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"shopware","vendor":"shopware"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Shopware RCE Vulnerability","id":"CVE-2016-3109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"shopware:shopware","products":["shopware:shopware"],"type":"code_injection","year":"2016"},"n_packages":4,"n_references":4,"next":{"headline":"mod_cluster Denial of Service vulnerability","id":"CVE-2016-3110"},"packages":[{"ecosystem":"Packagist","fixed":["4.3.7"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-cj2f-96jq-phpp"},{"ecosystem":"Packagist","fixed":["4.3.7"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-cj2f-96jq-phpp"},{"ecosystem":"Packagist","fixed":["5.1.5"],"introduced":["5.0.0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-cj2f-96jq-phpp"},{"ecosystem":"Packagist","fixed":["5.1.5"],"introduced":["5.0.0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-cj2f-96jq-phpp"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2016-3108"},"products":["n/a"],"published":"2017-04-21","related":[{"cvss_score":10,"headline":"Improper Control of Generation of Code in Twig rendered views in shopware","id":"CVE-2023-22731","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.3,"headline":"Blind SQL-injection in DAL aggregations in Shopware","id":"CVE-2024-22406","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":9.1,"headline":"Leak of information via Store-API","id":"CVE-2021-32711","kev_date_added":null,"published":"2021-06-24"},{"cvss_score":8.9,"headline":"Shopware unauthenticated data extraction possible through store-api.order endpoint","id":"CVE-2026-31887","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.9,"headline":"Shopware has a potential take over of app credentials","id":"CVE-2026-31889","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.8,"headline":"Improper Control of Generation of Code in Twig Rendered Views in Shopware","id":"CVE-2023-2017","kev_date_added":null,"published":"2023-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via the backend login script in Shopware, requiring an upgrade to secure the e-commerce platform.","url":"https://insights.sbomify.com/CVE-2016-3109/"}