# CVE-2016-3109: Shopware RCE Vulnerability

> Remote attackers can execute arbitrary code via the backend login script in Shopware, requiring an upgrade to secure the e-commerce platform.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cj2f-96jq-phpp

## What is CVE-2016-3109?

CVE-2016-3109 is a critical code injection vulnerability in Shopware Shopware, published on 21 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-3109?

4 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | All versions | 4.3.7 |
| `shopware/shopware` | Packagist | All versions | 4.3.7 |
| `shopware/shopware` | Packagist | From 5.0.0 | 5.1.5 |
| `shopware/shopware` | Packagist | From 5.0.0 | 5.1.5 |

Products: Shopware Shopware.

## How do I fix CVE-2016-3109?

Upgrade shopware/shopware to a fixed version for your release line: 4.3.7 or 5.1.5.

## Is CVE-2016-3109 being exploited?

There is no known exploitation of CVE-2016-3109 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)
- [CVE-2026-31889](https://insights.sbomify.com/CVE-2026-31889/): Shopware has a potential take over of app credentials (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3109 and fix it if it is affected.

What it is: CVE-2016-3109 is a critical code injection vulnerability in Shopware Shopware, published on 21 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3109 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected all versions; fixed in 4.3.7
- shopware/shopware (Packagist): affected all versions; fixed in 4.3.7
- shopware/shopware (Packagist): affected from 5.0.0; fixed in 5.1.5
- shopware/shopware (Packagist): affected from 5.0.0; fixed in 5.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3109/ (Markdown: https://insights.sbomify.com/CVE-2016-3109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3109
- OSV: https://osv.dev/vulnerability/CVE-2016-3109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3109/
Summaries are generated and may contain mistakes; the official description above is the record.
