# CVE-2016-3110: mod_cluster Denial of Service vulnerability

> Remote attackers can crash the Apache HTTP server by sending malformed MCMP messages, affecting JBoss Web Server availability.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-68qq-3phh-53j7

## What is CVE-2016-3110?

CVE-2016-3110 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mod_cluster, as used in Red Hat JBoss Web Server 2.1, allows remote attackers to cause a denial of service (Apache http server crash) via an MCMP message containing a series of = (equals) characters after a legitimate element.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-3110?

2 open source packages ship an affected version, including org.jboss.mod_cluster:mod_cluster-parent. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.mod_cluster:mod_cluster-parent` | Maven | All versions | 1.3.3.Final |
| `org.jboss.mod_cluster:mod_cluster-parent` | Maven | All versions | 1.3.3.Final |

Products: Fedoraproject Fedora, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Web Server.

## How do I fix CVE-2016-3110?

Upgrade org.jboss.mod_cluster:mod_cluster-parent to 1.3.3.Final or later.

## Is CVE-2016-3110 being exploited?

There is no known exploitation of CVE-2016-3110 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3110 and fix it if it is affected.

What it is: CVE-2016-3110 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3110 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.mod_cluster:mod_cluster-parent (Maven): affected all versions; fixed in 1.3.3.Final
- org.jboss.mod_cluster:mod_cluster-parent (Maven): affected all versions; fixed in 1.3.3.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3110/ (Markdown: https://insights.sbomify.com/CVE-2016-3110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3110
- OSV: https://osv.dev/vulnerability/CVE-2016-3110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3110/
Summaries are generated and may contain mistakes; the official description above is the record.
