# CVE-2016-3124: SimpleSAMLphp Information leakage issue in the sanitycheck module

> Remote attackers can learn the PHP version on the system via the sanitycheck module in SimpleSAMLphp.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-3124, GHSA-9327-mqm6-x97j, UBUNTU-CVE-2016-3124

## What is CVE-2016-3124?

CVE-2016-3124 is a medium-severity vulnerability in n/a, published on 7 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The sanitycheck module in SimpleSAMLphp before 1.14.1 allows remote attackers to learn the PHP version on the system via unspecified vectors.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-3124?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.14.1 |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.14.1 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2016-3124?

Upgrade simplesamlphp/simplesamlphp to 1.14.1 or later.

## Is CVE-2016-3124 being exploited?

There is no known exploitation of CVE-2016-3124 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3124 and fix it if it is affected.

What it is: CVE-2016-3124 is a medium-severity vulnerability in n/a, published on 7 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3124 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.1
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3124/ (Markdown: https://insights.sbomify.com/CVE-2016-3124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3124
- OSV: https://osv.dev/vulnerability/CVE-2016-3124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3124/
Summaries are generated and may contain mistakes; the official description above is the record.
