CVE-2016-3162 Drupal File upload access bypass and denial of service
Authenticated users can bypass access restrictions to read, delete, or substitute files in unprocessed forms, requiring an upgrade to Drupal.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3162?
CVE-2016-3162 is a high-severity missing authorization vulnerability in Debian Debian Linux, published on 12 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The File module in Drupal 7.x before 7.43 and 8.x before 8.0.4 allows remote authenticated users to bypass access restrictions and read, delete, or substitute a link to a file uploaded to an unprocessed form by leveraging permission to create content or comment and upload files.
Weakness: CWE-284
Which versions are affected by CVE-2016-3162?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 8.0 | 8.0.4 |
drupal/core Packagist | From 8.0 | 8.0.4 |
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 7.0 | 7.43 |
2 more packages
drupal/drupal Packagist | From 8.0 | 8.0.4 |
drupal/drupal Packagist | From 8.0 | 8.0.4 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2016-3162?
Upgrade drupal/core to a fixed version for your release line: 7.43 or 8.0.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2016-3162 being exploited?
There is no known exploitation of CVE-2016-3162 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-w2pj-c8x5-jvg2, UBUNTU-CVE-2016-3162.