CVE-2016-3163 Drupal Brute force amplification attacks via XML-RPC
Remote attackers can perform brute-force attacks against Drupal's XML-RPC system by sending numerous simultaneous calls, potentially causing service disruption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3163?
CVE-2016-3163 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.
Weakness: CWE-254
Which versions are affected by CVE-2016-3163?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 6.0 | 6.38 |
drupal/drupal Packagist | From 6.0 | 6.38 |
2 more packages
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 7.0 | 7.43 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2016-3163?
Upgrade drupal/core to a fixed version for your release line: 6.38 or 7.43.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-3163 being exploited?
There is no known exploitation of CVE-2016-3163 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-h3r9-pjmr-f938, UBUNTU-CVE-2016-3163.