# CVE-2016-3163: Drupal Brute force amplification attacks via XML-RPC

> Remote attackers can perform brute-force attacks against Drupal's XML-RPC system by sending numerous simultaneous calls, potentially causing service disruption.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h3r9-pjmr-f938, UBUNTU-CVE-2016-3163

## What is CVE-2016-3163?

CVE-2016-3163 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.

Weakness: CWE-254

## Which versions are affected by CVE-2016-3163?

8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 6.0 | 6.38 |
| `drupal/core` | Packagist | From 6.0 | 6.38 |
| `drupal/core` | Packagist | From 7.0 | 7.43 |
| `drupal/core` | Packagist | From 7.0 | 7.43 |
| `drupal/drupal` | Packagist | From 6.0 | 6.38 |
| `drupal/drupal` | Packagist | From 6.0 | 6.38 |
| `drupal/drupal` | Packagist | From 7.0 | 7.43 |
| `drupal/drupal` | Packagist | From 7.0 | 7.43 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2016-3163?

Upgrade drupal/core to a fixed version for your release line: 6.38 or 7.43.

## Is CVE-2016-3163 being exploited?

There is no known exploitation of CVE-2016-3163 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3163 and fix it if it is affected.

What it is: CVE-2016-3163 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3163 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 6.0; fixed in 6.38
- drupal/core (Packagist): affected from 6.0; fixed in 6.38
- drupal/core (Packagist): affected from 7.0; fixed in 7.43
- drupal/core (Packagist): affected from 7.0; fixed in 7.43
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.38
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.38
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.43
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.43

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3163/ (Markdown: https://insights.sbomify.com/CVE-2016-3163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3163
- OSV: https://osv.dev/vulnerability/CVE-2016-3163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3163/
Summaries are generated and may contain mistakes; the official description above is the record.
