CVE-2016-3164 Drupal Open Redirect
Remote attackers can redirect users to malicious sites via path manipulation in Drupal, requiring custom code or specific error page configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-3164?
CVE-2016-3164 is a high-severity vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Drupal 6.x before 6.38, 7.x before 7.43, and 8.x before 8.0.4 might allow remote attackers to conduct open redirect attacks by leveraging (1) custom code or (2) a form shown on a 404 error page, related to path manipulation.
Which versions are affected by CVE-2016-3164?
12 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 8.0 | 8.0.4 |
drupal/core Packagist | From 8.0 | 8.0.4 |
6 more packages
drupal/drupal Packagist | From 6.0 | 6.38 |
drupal/drupal Packagist | From 6.0 | 6.38 |
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 8.0 | 8.0.4 |
drupal/drupal Packagist | From 8.0 | 8.0.4 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2016-3164?
Upgrade drupal/core to a fixed version for your release line: 6.38, 7.43 or 8.0.4.
Is CVE-2016-3164 being exploited?
There is no known exploitation of CVE-2016-3164 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-836p-6p4j-35cg, UBUNTU-CVE-2016-3164.