# CVE-2016-3165: Drupal Form API ignores access restrictions on submit buttons

> Remote attackers can bypass intended access restrictions on form submit buttons in Drupal 6.x by leveraging specific permissions.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4gh5-3hqj-x3pj

## What is CVE-2016-3165?

CVE-2016-3165 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Form API in Drupal 6.x before 6.38 ignores access restrictions on submit buttons, which might allow remote attackers to bypass intended access restrictions by leveraging permission to submit a form with a button that has "#access" set to FALSE in the server-side form definition.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-3165?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 6.0 | 6.38 |
| `drupal/core` | Packagist | From 6.0 | 6.38 |
| `drupal/drupal` | Packagist | From 6.0 | 6.38 |
| `drupal/drupal` | Packagist | From 6.0 | 6.38 |

Products: Drupal Drupal.

## How do I fix CVE-2016-3165?

Upgrade drupal/core to 6.38 or later.

## Is CVE-2016-3165 being exploited?

There is no known exploitation of CVE-2016-3165 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3165 and fix it if it is affected.

What it is: CVE-2016-3165 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3165 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 6.0; fixed in 6.38
- drupal/core (Packagist): affected from 6.0; fixed in 6.38
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.38
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3165/ (Markdown: https://insights.sbomify.com/CVE-2016-3165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3165
- OSV: https://osv.dev/vulnerability/CVE-2016-3165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3165/
Summaries are generated and may contain mistakes; the official description above is the record.
