{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-3167 in the wild and no public exploit code.","fix":"Upgrade drupal/core to 6.38 or later.","what":"CVE-2016-3167 is a high-severity vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-3167 and fix it if it is affected.\n\nWhat it is: CVE-2016-3167 is a high-severity vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-3167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 6.0; fixed in 6.38\n- drupal/core (Packagist): affected from 6.0; fixed in 6.38\n- drupal/drupal (Packagist): affected from 6.0; fixed in 6.38\n- drupal/drupal (Packagist): affected from 6.0; fixed in 6.38\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3167/ (Markdown: https://insights.sbomify.com/CVE-2016-3167/index.md)","id":"CVE-2016-3167","markdown":"https://insights.sbomify.com/CVE-2016-3167/index.md","name":"CVE-2016-3167","record":{"aliases":["GHSA-gxwx-c7m8-f95h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal CMS","requires_auth":"none","summary":"Remote attackers can redirect users to arbitrary sites via double-encoded URLs in Drupal 6.x, facilitating phishing attacks.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"drupal","vendor":"drupal"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N","version":"3.0"},"cwes":[],"description":"Open redirect vulnerability in the drupal_goto function in Drupal 6.x before 6.38, when used with PHP before 5.4.7, allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a double-encoded URL in the \"destination\" parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal Open redirect vulnerability in the drupal_goto function","id":"CVE-2016-3167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","drupal:drupal"],"type":"open_redirect","year":"2016"},"n_packages":4,"n_references":4,"next":{"headline":"Drupal Reflected file download vulnerability","id":"CVE-2016-3168"},"packages":[{"ecosystem":"Packagist","fixed":["6.38"],"introduced":["6.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-gxwx-c7m8-f95h"},{"ecosystem":"Packagist","fixed":["6.38"],"introduced":["6.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-gxwx-c7m8-f95h"},{"ecosystem":"Packagist","fixed":["6.38"],"introduced":["6.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-gxwx-c7m8-f95h"},{"ecosystem":"Packagist","fixed":["6.38"],"introduced":["6.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-gxwx-c7m8-f95h"}],"prev":{"headline":"Drupal CRLF injection vulnerability in the drupal_set_header function","id":"CVE-2016-3166"},"products":["n/a"],"published":"2016-04-12","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can redirect users to arbitrary sites via double-encoded URLs in Drupal 6.x, facilitating phishing attacks.","url":"https://insights.sbomify.com/CVE-2016-3167/"}