CVE-2016-3168 Drupal Reflected file download vulnerability
Remote attackers can hijack administrator authentication via reflected file downloads, potentially leading to account takeover and code execution in Drupal.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-3168?
CVE-2016-3168 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
The System module in Drupal 6.x before 6.38 and 7.x before 7.43 might allow remote attackers to hijack the authentication of site administrators for requests that download and run files with arbitrary JSON-encoded content, aka a "reflected file download vulnerability."
Weakness: CWE-254
Which versions are affected by CVE-2016-3168?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 6.0 | 6.38 |
drupal/drupal Packagist | From 6.0 | 6.38 |
2 more packages
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 7.0 | 7.43 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2016-3168?
Upgrade drupal/core to a fixed version for your release line: 6.38 or 7.43.
Is CVE-2016-3168 being exploited?
There is no known exploitation of CVE-2016-3168 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-qqxc-cppg-4xp8, UBUNTU-CVE-2016-3168.