CVE-2016-3169 Drupal saving user accounts can sometimes grant the user all roles
Remote attackers can gain privileges in Drupal if custom code improperly calls user_save with explicit categories, requiring specific contributed or custom code usage.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3169?
CVE-2016-3169 is a high-severity vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The User module in Drupal 6.x before 6.38 and 7.x before 7.43 allows remote attackers to gain privileges by leveraging contributed or custom code that calls the user_save function with an explicit category and loads all roles into the array.
Weakness: CWE-264
Which versions are affected by CVE-2016-3169?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 6.0 | 6.38 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 6.0 | 6.38 |
drupal/drupal Packagist | From 6.0 | 6.38 |
2 more packages
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 7.0 | 7.43 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2016-3169?
Upgrade drupal/core to a fixed version for your release line: 6.38 or 7.43.
Is CVE-2016-3169 being exploited?
There is no known exploitation of CVE-2016-3169 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-q3p9-8728-wq7x, UBUNTU-CVE-2016-3169.