CVE-2016-3170 Drupal sensitive information disclosure
Remote attackers can obtain sensitive username information via password reset links in Drupal when specific login configurations are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3170?
CVE-2016-3170 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The "have you forgotten your password" links in the User module in Drupal 7.x before 7.43 and 8.x before 8.0.4 allow remote attackers to obtain sensitive username information by leveraging a configuration that permits using an email address to login and a module that permits logging in.
Weakness: CWE-200
Which versions are affected by CVE-2016-3170?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 7.0 | 7.43 |
drupal/core Packagist | From 8.0 | 8.0.4 |
drupal/core Packagist | From 8.0 | 8.0.4 |
drupal/drupal Packagist | From 7.0 | 7.43 |
drupal/drupal Packagist | From 7.0 | 7.43 |
2 more packages
drupal/drupal Packagist | From 8.0 | 8.0.4 |
drupal/drupal Packagist | From 8.0 | 8.0.4 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2016-3170?
Upgrade drupal/core to a fixed version for your release line: 7.43 or 8.0.4.
Is CVE-2016-3170 being exploited?
There is no known exploitation of CVE-2016-3170 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-pqv4-xgqh-j8vh, UBUNTU-CVE-2016-3170.