# CVE-2016-3674: XML External Entity Injection in XStream

> Remote attackers can read arbitrary files via crafted XML documents due to XML External Entity vulnerabilities in XStream drivers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2016
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2016-3674, DLA-504-1, DSA-3575-1, GHSA-rgh3-987h-wpmw, MGASA-2016-0164, UBUNTU-CVE-2016-3674

## What is CVE-2016-3674?

CVE-2016-3674 is a high-severity vulnerability in Debian Debian Linux, published on 17 May 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple XML external entity (XXE) vulnerabilities in the (1) Dom4JDriver, (2) DomDriver, (3) JDomDriver, (4) JDom2Driver, (5) SjsxpDriver, (6) StandardStaxDriver, and (7) WstxDriver drivers in XStream before 1.4.9 allow remote attackers to read arbitrary files via a crafted XML document.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-3674?

2 open source packages ship an affected version, including com.thoughtworks.xstream:xstream. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.9 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.9 |

Products: Debian Debian Linux, Fedoraproject Fedora, Redhat Jboss Middleware, Xstream Xstream.

## How do I fix CVE-2016-3674?

Upgrade com.thoughtworks.xstream:xstream to 1.4.9 or later.

## Is CVE-2016-3674 being exploited?

There is no known exploitation of CVE-2016-3674 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3674 and fix it if it is affected.

What it is: CVE-2016-3674 is a high-severity vulnerability in Debian Debian Linux, published on 17 May 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3674 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.9
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3674/ (Markdown: https://insights.sbomify.com/CVE-2016-3674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3674
- OSV: https://osv.dev/vulnerability/CVE-2016-3674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3674/
Summaries are generated and may contain mistakes; the official description above is the record.
