# CVE-2016-3720: jackson-dataformat-xml vulnerable to XML external entity (XXE)

> Attackers can exploit an XML External Entity vulnerability in the Jackson XML library to read sensitive data or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-3720, GHSA-hmq6-frv3-4727, MGASA-2016-0175, UBUNTU-CVE-2016-3720

## What is CVE-2016-3720?

CVE-2016-3720 is a critical vulnerability in Fedoraproject Fedora, published on 10 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XML external entity (XXE) vulnerability in XmlMapper in the Data format extension for Jackson (aka jackson-dataformat-xml) allows attackers to have unspecified impact via unknown vectors.

## Which versions are affected by CVE-2016-3720?

2 open source packages ship an affected version, including com.fasterxml.jackson.dataformat:jackson-dataformat-xml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.dataformat:jackson-dataformat-xml` | Maven | All versions | 2.7.4 |
| `com.fasterxml.jackson.dataformat:jackson-dataformat-xml` | Maven | All versions | 2.7.4 |

Products: Fasterxml Jackson-Dataformat-Xml, Fedoraproject Fedora.

## How do I fix CVE-2016-3720?

Upgrade com.fasterxml.jackson.dataformat:jackson-dataformat-xml to 2.7.4 or later.

## Is CVE-2016-3720 being exploited?

There is no known exploitation of CVE-2016-3720 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2016-7051](https://insights.sbomify.com/CVE-2016-7051/): jackson-dataformat-xml vulnerable to server side request forgery (SSRF) (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3720 and fix it if it is affected.

What it is: CVE-2016-3720 is a critical vulnerability in Fedoraproject Fedora, published on 10 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3720 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.dataformat:jackson-dataformat-xml (Maven): affected all versions; fixed in 2.7.4
- com.fasterxml.jackson.dataformat:jackson-dataformat-xml (Maven): affected all versions; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3720/ (Markdown: https://insights.sbomify.com/CVE-2016-3720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3720
- OSV: https://osv.dev/vulnerability/CVE-2016-3720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3720/
Summaries are generated and may contain mistakes; the official description above is the record.
