{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-3722 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to 2.3 or later.","what":"CVE-2016-3722 is a medium-severity denial of service vulnerability in Jenkins Jenkins, published on 17 May 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3722 and fix it if it is affected.\n\nWhat it is: CVE-2016-3722 is a medium-severity denial of service vulnerability in Jenkins Jenkins, published on 17 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3722 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.3\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3722/ (Markdown: https://insights.sbomify.com/CVE-2016-3722/index.md)","id":"CVE-2016-3722","markdown":"https://insights.sbomify.com/CVE-2016-3722/index.md","name":"CVE-2016-3722","record":{"aliases":["GHSA-3857-xm38-jmq2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI server","requires_auth":"low_privilege","summary":"Authenticated users can cause a denial of service by editing their full name, preventing login for affected accounts.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"jenkins"},{"product":"openshift","vendor":"redhat"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Jenkins before 2.3 and LTS before 1.651.2 allow remote authenticated users with multiple accounts to cause a denial of service (unable to login) by editing the \"full name.\"","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Authorization in Jenkins Core","id":"CVE-2016-3722","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins","redhat:openshift"],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":4,"next":{"headline":"Exposure of Sensitive Information in Jenkins Core","id":"CVE-2016-3723"},"packages":[{"ecosystem":"Maven","fixed":["2.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-3857-xm38-jmq2"},{"ecosystem":"Maven","fixed":["2.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-3857-xm38-jmq2"}],"prev":{"headline":"Jenkins allows Remote Users to Inject Build Parameters","id":"CVE-2016-3721"},"products":["n/a"],"published":"2016-05-17","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can cause a denial of service by editing their full name, preventing login for affected accounts.","url":"https://insights.sbomify.com/CVE-2016-3722/"}