CVE-2016-3724 Jenkins Exposes Sensitive Information from Job Configuration
Authenticated users with read access can expose sensitive password information by viewing job configurations in Jenkins.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3724?
CVE-2016-3724 is a medium-severity vulnerability in Jenkins Jenkins, published on 17 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Jenkins before 2.3 and LTS before 1.651.2 allow remote authenticated users with extended read access to obtain sensitive password information by reading a job configuration.
Weakness: CWE-200
Which versions are affected by CVE-2016-3724?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.651.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.651.2 |
org.jenkins-ci.main:jenkins-core Maven | From 1.652 | 2.3 |
org.jenkins-ci.main:jenkins-core Maven | From 1.652 | 2.3 |
Products include Jenkins Jenkins, Redhat Openshift.
How do I fix CVE-2016-3724?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.651.2 or 2.3.
Is CVE-2016-3724 being exploited?
There is no known exploitation of CVE-2016-3724 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-7vvj-qqvj-h8mc.