CVE-2016-3727 Jenkins Exposes Sensitive Information via API URL

Medium 4.3 Published Updated

Authenticated users with extended read permissions can access sensitive global configuration details via the Jenkins API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-3727?

CVE-2016-3727 is a medium-severity vulnerability in Jenkins Jenkins, published on 17 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The API URL computer/(master)/api/xml in Jenkins before 2.3 and LTS before 1.651.2 allows remote authenticated users with extended read permission for the master node to obtain sensitive information about the global configuration via unspecified vectors.

Weakness: CWE-200

Which versions are affected by CVE-2016-3727?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.651.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.651.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6522.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.6522.3

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2016-3727?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.651.2 or 2.3.

Is CVE-2016-3727 being exploited?

There is no known exploitation of CVE-2016-3727 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-6cr3-cm5h-8q96.

Is CVE-2016-3727 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free