CVE-2016-3729 Moodle Improper Access Control
Authenticated users can modify administrator-locked profile fields in Moodle, allowing unauthorized data modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3729?
CVE-2016-3729 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The user editing form in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to edit profile fields locked by the administrator.
Weakness: CWE-284
Which versions are affected by CVE-2016-3729?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7 | 2.7.14 |
moodle/moodle Packagist | From 2.7 | 2.7.14 |
moodle/moodle Packagist | From 2.8 | 2.8.12 |
moodle/moodle Packagist | From 2.8 | 2.8.12 |
moodle/moodle Packagist | From 2.9 | 2.9.6 |
moodle/moodle Packagist | From 2.9 | 2.9.6 |
2 more packages
moodle/moodle Packagist | From 3.0 | 3.0.3 |
moodle/moodle Packagist | From 3.0 | 3.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2016-3729?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.14, 2.8.12, 2.9.6 or 3.0.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2016-3729 being exploited?
There is no known exploitation of CVE-2016-3729 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-g96h-wvrm-c2ww.