CVE-2016-3732 Moodle sensitive information disclosure

Medium 4.3 Published Updated

Authenticated users can improperly access other users' badges due to insufficient capability checks in Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-3732?

CVE-2016-3732 is a medium-severity vulnerability in Moodle Moodle, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.

Weakness: CWE-200

Which versions are affected by CVE-2016-3732?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 2.7.02.7.14
moodle/moodle PackagistFrom 2.7.02.7.14
moodle/moodle PackagistFrom 2.8.02.8.12
moodle/moodle PackagistFrom 2.8.02.8.12
moodle/moodle PackagistFrom 2.9.02.9.6
moodle/moodle PackagistFrom 2.9.02.9.6
2 more packages
moodle/moodle PackagistFrom 3.0.03.0.4
moodle/moodle PackagistFrom 3.0.03.0.4

Products include Moodle Moodle.

How do I fix CVE-2016-3732?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.14, 2.8.12, 2.9.6 or 3.0.4.

Is CVE-2016-3732 being exploited?

There is no known exploitation of CVE-2016-3732 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-5282-96ff-xx3h, UBUNTU-CVE-2016-3732.

Is CVE-2016-3732 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free