{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-3732 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.7.14, 2.8.12, 2.9.6 or 3.0.4.","what":"CVE-2016-3732 is a medium-severity vulnerability in Moodle Moodle, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3732 and fix it if it is affected.\n\nWhat it is: CVE-2016-3732 is a medium-severity vulnerability in Moodle Moodle, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3732 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.14\n- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.14\n- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.12\n- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.12\n- moodle/moodle (Packagist): affected from 2.9.0; fixed in 2.9.6\n- moodle/moodle (Packagist): affected from 2.9.0; fixed in 2.9.6\n- moodle/moodle (Packagist): affected from 3.0.0; fixed in 3.0.4\n- moodle/moodle (Packagist): affected from 3.0.0; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3732/ (Markdown: https://insights.sbomify.com/CVE-2016-3732/index.md)","id":"CVE-2016-3732","markdown":"https://insights.sbomify.com/CVE-2016-3732/index.md","name":"CVE-2016-3732","record":{"aliases":["GHSA-5282-96ff-xx3h","UBUNTU-CVE-2016-3732"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Authenticated users can improperly access other users' badges due to insufficient capability checks in Moodle.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle sensitive information disclosure","id":"CVE-2016-3732","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"information_disclosure","year":"2016"},"n_packages":8,"n_references":3,"next":{"headline":"Moodle Improper Access Control","id":"CVE-2016-3733"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.14"],"introduced":["2.7.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["2.7.14"],"introduced":["2.7.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["2.8.12"],"introduced":["2.8.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["2.8.12"],"introduced":["2.8.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["2.9.6"],"introduced":["2.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["2.9.6"],"introduced":["2.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["3.0.4"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-5282-96ff-xx3h"},{"ecosystem":"Packagist","fixed":["3.0.4"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-5282-96ff-xx3h"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-3731"},"products":["n/a"],"published":"2017-04-20","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can improperly access other users' badges due to insufficient capability checks in Moodle.","url":"https://insights.sbomify.com/CVE-2016-3732/"}