CVE-2016-3734 Moodle Cross-site request forgery (CSRF) vulnerability

High 8.8 Published Updated

Remote attackers can hijack user authentication to mark forum posts as read in Moodle via a CSRF vulnerability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-3734?

CVE-2016-3734 is a high-severity vulnerability in Moodle Moodle, published on 20 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Weakness: CWE-352

Which versions are affected by CVE-2016-3734?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.7.14
moodle/moodle PackagistAll versions2.7.14
moodle/moodle PackagistFrom 2.82.8.12
moodle/moodle PackagistFrom 2.82.8.12
moodle/moodle PackagistFrom 2.92.9.6
moodle/moodle PackagistFrom 2.92.9.6
2 more packages
moodle/moodle PackagistFrom 3.03.0.4
moodle/moodle PackagistFrom 3.03.0.4

Products include Moodle Moodle.

How do I fix CVE-2016-3734?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.14, 2.8.12, 2.9.6 or 3.0.4.

Is CVE-2016-3734 being exploited?

There is no known exploitation of CVE-2016-3734 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-r867-v437-4rrm.

Is CVE-2016-3734 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free