# CVE-2016-3953: web2py remote code execution via hardcoded encryption key in session.connect function

> Remote attackers can execute arbitrary code in the web2py sample application due to a hardcoded encryption key used in session connections.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-q2rq-qgcf-m22w, PYSEC-2026-570, UBUNTU-CVE-2016-3953

## What is CVE-2016-3953?

CVE-2016-3953 is a critical vulnerability in n/a, published on 6 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The sample web application in web2py before 2.14.2 might allow remote attackers to execute arbitrary code via vectors involving use of a hardcoded encryption key when calling the session.connect function.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2016-3953?

3 open source packages ship an affected version, including web2py. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web2py` | PyPI | All versions | 2.14.2 |
| `web2py` | PyPI | All versions | 2.14.2 |
| `web2py` | PyPI | All versions | 2.14.2 |

Products: Web2py Web2py.

## How do I fix CVE-2016-3953?

Upgrade web2py to 2.14.2 or later.

## Is CVE-2016-3953 being exploited?

There is no known exploitation of CVE-2016-3953 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-45158](https://insights.sbomify.com/CVE-2023-45158/): Command injection in web2py (critical 9.8)
- [CVE-2016-3957](https://insights.sbomify.com/CVE-2016-3957/): Deserialization in n/a (critical 9.8)
- [CVE-2016-10321](https://insights.sbomify.com/CVE-2016-10321/): web2py is vulnerable to password brute-force attack (critical 9.8)
- [CVE-2016-4808](https://insights.sbomify.com/CVE-2016-4808/): Web2py Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2016-3952](https://insights.sbomify.com/CVE-2016-3952/): Information disclosure in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3953 and fix it if it is affected.

What it is: CVE-2016-3953 is a critical vulnerability in n/a, published on 6 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3953 in the wild and no public exploit code.

Affected packages and fixed versions:
- web2py (PyPI): affected all versions; fixed in 2.14.2
- web2py (PyPI): affected all versions; fixed in 2.14.2
- web2py (PyPI): affected all versions; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3953/ (Markdown: https://insights.sbomify.com/CVE-2016-3953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3953
- OSV: https://osv.dev/vulnerability/CVE-2016-3953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3953/
Summaries are generated and may contain mistakes; the official description above is the record.
