# CVE-2016-3954: web2py exposure of sensitive information

> Remote attackers can obtain the session cookie key via a direct request, potentially leading to further exploitation.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jr83-vr4j-mp6p, PYSEC-2026-1062, UBUNTU-CVE-2016-3954

## What is CVE-2016-3954?

CVE-2016-3954 is a medium-severity vulnerability in n/a, published on 6 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

web2py before 2.14.2 allows remote attackers to obtain the session_cookie_key value via a direct request to examples/simple_examples/status.  NOTE: this issue can be leveraged by remote attackers to execute arbitrary code using CVE-2016-3957.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-3954?

3 open source packages ship an affected version, including web2py. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web2py` | PyPI | All versions | 2.14.2 |
| `web2py` | PyPI | All versions | 2.14.2 |
| `web2py` | PyPI | All versions | 2.14.2 |

Products: Web2py Web2py.

## How do I fix CVE-2016-3954?

Upgrade web2py to 2.14.2 or later.

## Is CVE-2016-3954 being exploited?

There is no known exploitation of CVE-2016-3954 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-45158](https://insights.sbomify.com/CVE-2023-45158/): Command injection in web2py (critical 9.8)
- [CVE-2016-3953](https://insights.sbomify.com/CVE-2016-3953/): web2py remote code execution via hardcoded encryption key in session.connect function (critical 9.8)
- [CVE-2016-3957](https://insights.sbomify.com/CVE-2016-3957/): Deserialization in n/a (critical 9.8)
- [CVE-2016-10321](https://insights.sbomify.com/CVE-2016-10321/): web2py is vulnerable to password brute-force attack (critical 9.8)
- [CVE-2016-4808](https://insights.sbomify.com/CVE-2016-4808/): Web2py Cross-Site Request Forgery vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3954 and fix it if it is affected.

What it is: CVE-2016-3954 is a medium-severity vulnerability in n/a, published on 6 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3954 in the wild and no public exploit code.

Affected packages and fixed versions:
- web2py (PyPI): affected all versions; fixed in 2.14.2
- web2py (PyPI): affected all versions; fixed in 2.14.2
- web2py (PyPI): affected all versions; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3954/ (Markdown: https://insights.sbomify.com/CVE-2016-3954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3954
- OSV: https://osv.dev/vulnerability/CVE-2016-3954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3954/
Summaries are generated and may contain mistakes; the official description above is the record.
