{"answers":{"affected":"4 open source packages ship an affected version, including npm. It affects 3 products.","exploited":"There is no known exploitation of CVE-2016-3956 in the wild and no public exploit code.","fix":"Upgrade npm to a fixed version for your release line: 2.15.1 or 3.8.3.","what":"CVE-2016-3956 is a high-severity vulnerability in Nodejs Node.js, published on 2 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3956 and fix it if it is affected.\n\nWhat it is: CVE-2016-3956 is a high-severity vulnerability in Nodejs Node.js, published on 2 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3956 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- npm (npm): affected all versions; fixed in 2.15.1\n- npm (npm): affected all versions; fixed in 2.15.1\n- npm (npm): affected from 3.0.0; fixed in 3.8.3\n- npm (npm): affected from 3.0.0; fixed in 3.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3956/ (Markdown: https://insights.sbomify.com/CVE-2016-3956/index.md)","id":"CVE-2016-3956","markdown":"https://insights.sbomify.com/CVE-2016-3956/index.md","name":"CVE-2016-3956","record":{"aliases":["CVE-2016-1000014","DEBIAN-CVE-2016-3956","GHSA-m5h6-hr3q-22h5","MINI-rqw2-fqcx-hhfg","UBUNTU-CVE-2016-3956","USN-4785-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"npm CLI","requires_auth":"none","summary":"The npm CLI sends bearer tokens to arbitrary remote servers, allowing attackers to steal sensitive authentication information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"sdk","vendor":"ibm"},{"product":"node.js","vendor":"nodejs"},{"product":"npm","vendor":"npmjs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests, which allows remote HTTP servers to obtain sensitive information by reading Authorization headers.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"npm Token Leak in npm","id":"CVE-2016-3956","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"information_disclosure","year":"2016"},"n_packages":4,"n_references":6,"next":{"headline":"Deserialization in n/a","id":"CVE-2016-3957"},"packages":[{"ecosystem":"npm","fixed":["2.15.1"],"introduced":["0"],"last_affected":[],"package":"npm","purl":null,"source":"GHSA-m5h6-hr3q-22h5"},{"ecosystem":"npm","fixed":["2.15.1"],"introduced":["0"],"last_affected":[],"package":"npm","purl":"pkg:npm/npm","source":"GHSA-m5h6-hr3q-22h5"},{"ecosystem":"npm","fixed":["3.8.3"],"introduced":["3.0.0"],"last_affected":[],"package":"npm","purl":null,"source":"GHSA-m5h6-hr3q-22h5"},{"ecosystem":"npm","fixed":["3.8.3"],"introduced":["3.0.0"],"last_affected":[],"package":"npm","purl":"pkg:npm/npm","source":"GHSA-m5h6-hr3q-22h5"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2016-3955"},"products":["n/a"],"published":"2016-07-02","related":[{"cvss_score":8.2,"headline":"XML external entity in Runtimes for Java Technology","id":"CVE-2017-1289","kev_date_added":null,"published":"2017-05-22"},{"cvss_score":8.1,"headline":"IBM SDK, Java Technology Edition code execution","id":"CVE-2022-40609","kev_date_added":null,"published":"2023-08-02"},{"cvss_score":7.4,"headline":"Path traversal in SDK, Java Technology Edition","id":"CVE-2018-1656","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":7.2,"headline":"Other in Java","id":"CVE-2019-4732","kev_date_added":null,"published":"2020-02-03"},{"cvss_score":5.6,"headline":"Code injection in Runtimes for Java Technology","id":"CVE-2018-1890","kev_date_added":null,"published":"2019-03-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"The npm CLI sends bearer tokens to arbitrary remote servers, allowing attackers to steal sensitive authentication information.","url":"https://insights.sbomify.com/CVE-2016-3956/"}