CVE-2016-3959 Denial of service in n/a
Remote attackers can cause a denial of service via infinite loop in Go's DSA verification when processing crafted public keys in HTTPS or SSH contexts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3959?
CVE-2016-3959 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 23 May 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Verify function in crypto/dsa/dsa.go in Go before 1.5.4 and 1.6.x before 1.6.1 does not properly check parameters passed to the big integer library, which might allow remote attackers to cause a denial of service (infinite loop) via a crafted public key to a program that uses HTTPS client certificates or SSH server libraries.
Weakness: CWE-20
Which versions are affected by CVE-2016-3959?
1 open source package ship an affected version, including stdlib. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
stdlib Go | All versions | 1.5.4, 1.6.1 |
Products include Fedoraproject Fedora, Golang Go, Opensuse Leap.
How do I fix CVE-2016-3959?
Upgrade stdlib to a fixed version for your release line: 1.5.4 or 1.6.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-3959 being exploited?
There is no known exploitation of CVE-2016-3959 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as AZL-79052, AZL-98631, GHSA-w7w7-9368-hffm, GO-2022-0166, MGASA-2016-0207.