# CVE-2016-3959: Denial of service in n/a

> Remote attackers can cause a denial of service via infinite loop in Go's DSA verification when processing crafted public keys in HTTPS or SSH contexts.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 May 2016
- **Updated:** 6 Aug 2024
- **Also known as:** AZL-79052, AZL-98631, GHSA-w7w7-9368-hffm, GO-2022-0166, MGASA-2016-0207

## What is CVE-2016-3959?

CVE-2016-3959 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 23 May 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Verify function in crypto/dsa/dsa.go in Go before 1.5.4 and 1.6.x before 1.6.1 does not properly check parameters passed to the big integer library, which might allow remote attackers to cause a denial of service (infinite loop) via a crafted public key to a program that uses HTTPS client certificates or SSH server libraries.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-3959?

1 open source package ship an affected version, including stdlib. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stdlib` | Go | All versions | 1.5.4, 1.6.1 |

Products: Fedoraproject Fedora, Golang Go, Opensuse Leap.

## How do I fix CVE-2016-3959?

Upgrade stdlib to a fixed version for your release line: 1.5.4 or 1.6.1.

## Is CVE-2016-3959 being exploited?

There is no known exploitation of CVE-2016-3959 in the wild and no public exploit code.

Public exploit code:

- Analysis of CVE-2016-3959 and a Proof of Concept Attack Against a Go SSH Server.  (github_poc): https://github.com/alexmullins/dsa

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3959 and fix it if it is affected.

What it is: CVE-2016-3959 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 23 May 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3959 in the wild and no public exploit code.

Affected packages and fixed versions:
- stdlib (Go): affected all versions; fixed in 1.5.4, 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3959/ (Markdown: https://insights.sbomify.com/CVE-2016-3959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3959
- OSV: https://osv.dev/vulnerability/CVE-2016-3959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3959/
Summaries are generated and may contain mistakes; the official description above is the record.
