# CVE-2016-4000: Deserialization of Untrusted Data in Jython

> Attackers can execute arbitrary code by sending a crafted serialized PyFunction object to applications using the Jython library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4000, DLA-989-1, DSA-3893-1, GHSA-6r7r-jj8h-pq6v, UBUNTU-CVE-2016-4000

## What is CVE-2016-4000?

CVE-2016-4000 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jython before 2.7.1rc1 allows attackers to execute arbitrary code via a crafted serialized PyFunction object.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2016-4000?

4 open source packages ship an affected version, including org.python:jython and org.python:jython-standalone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.python:jython` | Maven | All versions | 2.7.1b3 |
| `org.python:jython` | Maven | All versions | 2.7.1b3 |
| `org.python:jython-standalone` | Maven | All versions | 2.7.1b3 |
| `org.python:jython-standalone` | Maven | All versions | 2.7.1b3 |

Products: Debian Debian Linux, Jython Project Jython.

## How do I fix CVE-2016-4000?

Upgrade org.python:jython to 2.7.1b3 or later.

## Is CVE-2016-4000 being exploited?

There is no known exploitation of CVE-2016-4000 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4000 and fix it if it is affected.

What it is: CVE-2016-4000 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4000 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.python:jython (Maven): affected all versions; fixed in 2.7.1b3
- org.python:jython (Maven): affected all versions; fixed in 2.7.1b3
- org.python:jython-standalone (Maven): affected all versions; fixed in 2.7.1b3
- org.python:jython-standalone (Maven): affected all versions; fixed in 2.7.1b3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4000/ (Markdown: https://insights.sbomify.com/CVE-2016-4000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4000
- OSV: https://osv.dev/vulnerability/CVE-2016-4000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4000/
Summaries are generated and may contain mistakes; the official description above is the record.
