CVE-2016-4041 Plone vulnerable to privilege escalation in WebDAV
Remote attackers can gain unauthorized WebDAV access to Dexterity content in Plone due to missing security declarations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4041?
CVE-2016-4041 is a high-severity missing authorization vulnerability in Plone Plone, published on 24 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Plone 4.0 through 5.1a1 does not have security declarations for Dexterity content-related WebDAV requests, which allows remote attackers to gain webdav access via unspecified vectors.
Weakness: CWE-264
Which versions are affected by CVE-2016-4041?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 3.3 | 4.3.10 |
plone PyPI | From 4.0 | 5.1a2 |
plone PyPI | From 5.0 | 5.0.5 |
plone PyPI | From 5.1a1 | 5.1a2 |
Plone PyPI | From 3.3 | 4.3.10 |
Plone PyPI | From 5.0 | 5.0.5 |
1 more packages
Plone PyPI | From 5.1a1 | 5.1a2 |
Products include Plone Plone.
How do I fix CVE-2016-4041?
Upgrade plone to a fixed version for your release line: 4.3.10, 5.1a2 or 5.0.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2016-4041 being exploited?
There is no known exploitation of CVE-2016-4041 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-qqgj-22gr-73vx, PYSEC-2017-55.