CVE-2016-4042 Plone vulnerable to unauthorized disclosure of site content
Remote attackers can obtain sensitive content IDs in Plone, potentially exposing internal data structures.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4042?
CVE-2016-4042 is a medium-severity vulnerability in Plone Plone, published on 24 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Plone 3.3 through 5.1a1 allows remote attackers to obtain information about the ID of sensitive content via unspecified vectors.
Weakness: CWE-200
Which versions are affected by CVE-2016-4042?
5 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 3.3 | 4.3.10 |
plone PyPI | From 3.3 | 5.1a2 |
plone PyPI | From 5.0 | 5.0.5 |
Plone PyPI | From 3.3 | 4.3.10 |
Plone PyPI | From 5.0 | 5.0.5 |
Products include Plone Plone.
How do I fix CVE-2016-4042?
Upgrade plone to a fixed version for your release line: 4.3.10, 5.1a2 or 5.0.5.
Is CVE-2016-4042 being exploited?
There is no known exploitation of CVE-2016-4042 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-v4vj-49m5-wjhw, PYSEC-2017-56.