# CVE-2016-4055: Regular Expression Denial of Service in moment

> Remote attackers can cause denial of service via CPU consumption in the moment library using a long string input.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4055, GHSA-87vv-r9j6-g5qv, ROOT-APP-NPM-CVE-2016-4055, UBUNTU-CVE-2016-4055

## What is CVE-2016-4055?

CVE-2016-4055 is a medium-severity denial of service vulnerability in Oracle Primavera Unifier, published on 23 Jan 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The duration function in the moment package before 2.11.2 for Node.js allows remote attackers to cause a denial of service (CPU consumption) via a long string, aka a "regular expression Denial of Service (ReDoS)."

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-4055?

2 open source packages ship an affected version, including moment. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moment` | npm | All versions | 2.11.2 |
| `moment` | npm | All versions | 2.11.2 |

Products: Momentjs Moment, Oracle Primavera Unifier, Tenable Nessus.

## How do I fix CVE-2016-4055?

Upgrade moment to 2.11.2 or later.

## Is CVE-2016-4055 being exploited?

There is no known exploitation of CVE-2016-4055 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Primavera Unifier

- [CVE-2017-18214](https://insights.sbomify.com/CVE-2017-18214/): Regular Expression Denial of Service in moment (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4055 and fix it if it is affected.

What it is: CVE-2016-4055 is a medium-severity denial of service vulnerability in Oracle Primavera Unifier, published on 23 Jan 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4055 in the wild and no public exploit code.

Affected packages and fixed versions:
- moment (npm): affected all versions; fixed in 2.11.2
- moment (npm): affected all versions; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4055/ (Markdown: https://insights.sbomify.com/CVE-2016-4055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4055
- OSV: https://osv.dev/vulnerability/CVE-2016-4055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4055/
Summaries are generated and may contain mistakes; the official description above is the record.
