# CVE-2016-4216: Moderate severity vulnerability that affects com.adobe.xmp:xmpcore

> Remote attackers can read arbitrary files via XML external entity injection in the Adobe XMP Toolkit for Java library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qv32-7r6p-xhhh, OESA-2026-1319, OESA-2026-1366, OESA-2026-1367, OESA-2026-1368, OESA-2026-1369, OESA-2026-1370, UBUNTU-CVE-2016-4216

## What is CVE-2016-4216?

CVE-2016-4216 is a high-severity vulnerability in n/a, published on 13 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XMPCore in Adobe XMP Toolkit for Java before 5.1.3 allows remote attackers to read arbitrary files via XML data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

## Which versions are affected by CVE-2016-4216?

2 open source packages ship an affected version, including com.adobe.xmp:xmpcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.adobe.xmp:xmpcore` | Maven | All versions | 5.1.3 |
| `com.adobe.xmp:xmpcore` | Maven | All versions | 5.1.3 |

Products: Adobe Xmp Toolkit.

## How do I fix CVE-2016-4216?

Upgrade com.adobe.xmp:xmpcore to 5.1.3 or later.

## Is CVE-2016-4216 being exploited?

There is no known exploitation of CVE-2016-4216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4216 and fix it if it is affected.

What it is: CVE-2016-4216 is a high-severity vulnerability in n/a, published on 13 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4216 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.adobe.xmp:xmpcore (Maven): affected all versions; fixed in 5.1.3
- com.adobe.xmp:xmpcore (Maven): affected all versions; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4216/ (Markdown: https://insights.sbomify.com/CVE-2016-4216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4216
- OSV: https://osv.dev/vulnerability/CVE-2016-4216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4216/
Summaries are generated and may contain mistakes; the official description above is the record.
