CVE-2016-4423 Symphony Denial of Service Via Overlong Usernames
Remote attackers can cause denial of service by exhausting session storage with long usernames during authentication attempts in Symfony.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4423?
CVE-2016-4423 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The attemptAuthentication function in Component/Security/Http/Firewall/UsernamePasswordFormAuthenticationListener.php in Symfony before 2.3.41, 2.7.x before 2.7.13, 2.8.x before 2.8.6, and 3.0.x before 3.0.6 does not limit the length of a username stored in a session, which allows remote attackers to cause a denial of service (session storage consumption) via a series of authentication attempts with long, non-existent usernames.
Weakness: CWE-399
Which versions are affected by CVE-2016-4423?
24 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.3.0 | 2.3.41 |
symfony/security Packagist | From 2.3.0 | 2.3.41 |
symfony/security Packagist | From 2.4.0 | 2.7.13 |
symfony/security Packagist | From 2.4.0 | 2.7.13 |
symfony/security Packagist | From 2.8.0 | 2.8.6 |
symfony/security Packagist | From 2.8.0 | 2.8.6 |
18 more packages
symfony/security Packagist | From 3.0.0 | 3.0.6 |
symfony/security Packagist | From 3.0.0 | 3.0.6 |
symfony/security-http Packagist | From 2.3.0 | 2.3.41 |
symfony/security-http Packagist | From 2.3.0 | 2.3.41 |
symfony/security-http Packagist | From 2.4.0 | 2.7.13 |
symfony/security-http Packagist | From 2.4.0 | 2.7.13 |
symfony/security-http Packagist | From 2.8.0 | 2.8.6 |
symfony/security-http Packagist | From 2.8.0 | 2.8.6 |
symfony/security-http Packagist | From 3.0.0 | 3.0.6 |
symfony/security-http Packagist | From 3.0.0 | 3.0.6 |
symfony/symfony Packagist | From 2.3.0 | 2.3.41 |
symfony/symfony Packagist | From 2.3.0 | 2.3.41 |
symfony/symfony Packagist | From 2.4.0 | 2.7.13 |
symfony/symfony Packagist | From 2.4.0 | 2.7.13 |
symfony/symfony Packagist | From 2.8.0 | 2.8.6 |
symfony/symfony Packagist | From 2.8.0 | 2.8.6 |
symfony/symfony Packagist | From 3.0.0 | 3.0.6 |
symfony/symfony Packagist | From 3.0.0 | 3.0.6 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2016-4423?
Upgrade symfony/security to a fixed version for your release line: 2.3.41, 2.7.13, 2.8.6 or 3.0.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-4423 being exploited?
There is no known exploitation of CVE-2016-4423 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2016-4423, GHSA-whgv-8cg3-7hcm, UBUNTU-CVE-2016-4423.