# CVE-2016-4423: Symphony Denial of Service Via Overlong Usernames

> Remote attackers can cause denial of service by exhausting session storage with long usernames during authentication attempts in Symfony.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4423, GHSA-whgv-8cg3-7hcm, UBUNTU-CVE-2016-4423

## What is CVE-2016-4423?

CVE-2016-4423 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The attemptAuthentication function in Component/Security/Http/Firewall/UsernamePasswordFormAuthenticationListener.php in Symfony before 2.3.41, 2.7.x before 2.7.13, 2.8.x before 2.8.6, and 3.0.x before 3.0.6 does not limit the length of a username stored in a session, which allows remote attackers to cause a denial of service (session storage consumption) via a series of authentication attempts with long, non-existent usernames.

Weakness: CWE-399

## Which versions are affected by CVE-2016-4423?

24 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.3.0 | 2.3.41 |
| `symfony/security` | Packagist | From 2.3.0 | 2.3.41 |
| `symfony/security` | Packagist | From 2.4.0 | 2.7.13 |
| `symfony/security` | Packagist | From 2.4.0 | 2.7.13 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.6 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.6 |
| `symfony/security` | Packagist | From 3.0.0 | 3.0.6 |
| `symfony/security` | Packagist | From 3.0.0 | 3.0.6 |
| `symfony/security-http` | Packagist | From 2.3.0 | 2.3.41 |
| `symfony/security-http` | Packagist | From 2.3.0 | 2.3.41 |
| `symfony/security-http` | Packagist | From 2.4.0 | 2.7.13 |
| `symfony/security-http` | Packagist | From 2.4.0 | 2.7.13 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.6 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.6 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.0.6 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.0.6 |
| `symfony/symfony` | Packagist | From 2.3.0 | 2.3.41 |
| `symfony/symfony` | Packagist | From 2.3.0 | 2.3.41 |
| `symfony/symfony` | Packagist | From 2.4.0 | 2.7.13 |
| `symfony/symfony` | Packagist | From 2.4.0 | 2.7.13 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.6 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.6 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.0.6 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.0.6 |

Products: Debian Debian Linux, Sensiolabs Symfony.

## How do I fix CVE-2016-4423?

Upgrade symfony/security to a fixed version for your release line: 2.3.41, 2.7.13, 2.8.6 or 3.0.6.

## Is CVE-2016-4423 being exploited?

There is no known exploitation of CVE-2016-4423 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4423 and fix it if it is affected.

What it is: CVE-2016-4423 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4423 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.3.0; fixed in 2.3.41
- symfony/security (Packagist): affected from 2.3.0; fixed in 2.3.41
- symfony/security (Packagist): affected from 2.4.0; fixed in 2.7.13
- symfony/security (Packagist): affected from 2.4.0; fixed in 2.7.13
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.6
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.6
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.0.6
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.0.6
- symfony/security-http (Packagist): affected from 2.3.0; fixed in 2.3.41
- symfony/security-http (Packagist): affected from 2.3.0; fixed in 2.3.41
- symfony/security-http (Packagist): affected from 2.4.0; fixed in 2.7.13
- symfony/security-http (Packagist): affected from 2.4.0; fixed in 2.7.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4423/ (Markdown: https://insights.sbomify.com/CVE-2016-4423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4423
- OSV: https://osv.dev/vulnerability/CVE-2016-4423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4423/
Summaries are generated and may contain mistakes; the official description above is the record.
