CVE-2016-4428 OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability
Remote authenticated users can inject arbitrary web script or HTML via AngularJS templates in OpenStack Dashboard forms.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-4428?
CVE-2016-4428 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 12 Jul 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.
Weakness: CWE-79
Which versions are affected by CVE-2016-4428?
5 open source packages ship an affected version, including horizon. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
horizon PyPI | All versions | 8.0.2, 9.1.0 |
horizon PyPI | All versions | 8.0.2 |
horizon PyPI | All versions | 8.0.2 |
horizon PyPI | From 9.0.0 | 9.1.0 |
horizon PyPI | From 9.0.0 | 9.1.0 |
Linux distribution packages (19)
openstack-dashboard Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
openstack-dashboard-theme Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
python-django-horizon Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
python-django-horizon-doc Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
openstack-dashboard Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
openstack-dashboard-theme Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
python-django-horizon Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
python-django-horizon-doc Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
openstack-dashboard Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
openstack-dashboard-theme Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
python-django-horizon Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
python-django-horizon-doc Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-9.el7ost |
openstack-dashboard Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-1.el7ost |
openstack-dashboard-theme Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-1.el7ost |
python-django-horizon Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-1.el7ost |
python-django-horizon-doc Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-1.el7ost |
openstack-dashboard Red Hat:openstack:8::el7 | All versions | 1:8.0.1-4.el7ost |
openstack-dashboard-theme Red Hat:openstack:8::el7 | All versions | 1:8.0.1-4.el7ost |
python-django-horizon Red Hat:openstack:8::el7 | All versions | 1:8.0.1-4.el7ost |
Products include Debian Debian Linux, Openstack Horizon, Redhat Openstack.
How do I fix CVE-2016-4428?
Upgrade horizon to a fixed version for your release line: 8.0.2 or 9.1.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-4428 being exploited?
There is no known exploitation of CVE-2016-4428 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2016-4428, DLA-520-1, GHSA-grm6-x6mr-q3cv, PYSEC-2026-643, RHSA-2016:1268, RHSA-2016:1269 and 5 more.