# CVE-2016-4434: Apache Tika does not properly initialize the XML parser or choose handlers

> Remote attackers can exploit XML External Entity vulnerabilities in Apache Tika to read sensitive files or cause denial of service via crafted documents.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4434, GHSA-4xr4-4c65-hj7f, UBUNTU-CVE-2016-4434

## What is CVE-2016-4434?

CVE-2016-4434 is a high-severity vulnerability in n/a, published on 29 Sep 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Apache Tika before 1.13 does not properly initialize the XML parser or choose handlers, which might allow remote attackers to conduct XML External Entity (XXE) attacks via vectors involving (1) spreadsheets in OOXML files and (2) XMP metadata in PDF and other file formats, a related issue to CVE-2016-2175.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2016-4434?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-core` | Maven | All versions | 1.13 |
| `org.apache.tika:tika-core` | Maven | All versions | 1.13 |

Products: Apache Tika.

## How do I fix CVE-2016-4434?

Upgrade org.apache.tika:tika-core to 1.13 or later.

## Is CVE-2016-4434 being exploited?

There is no known exploitation of CVE-2016-4434 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2025-54988](https://insights.sbomify.com/CVE-2025-54988/): Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA (high 8.4)
- [CVE-2018-1335](https://insights.sbomify.com/CVE-2018-1335/): Command injection in org.apache.tika:tika-core (high 8.1)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4434 and fix it if it is affected.

What it is: CVE-2016-4434 is a high-severity vulnerability in n/a, published on 29 Sep 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-4434 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tika:tika-core (Maven): affected all versions; fixed in 1.13
- org.apache.tika:tika-core (Maven): affected all versions; fixed in 1.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4434/ (Markdown: https://insights.sbomify.com/CVE-2016-4434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4434
- OSV: https://osv.dev/vulnerability/CVE-2016-4434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4434/
Summaries are generated and may contain mistakes; the official description above is the record.
