# CVE-2016-4436: Apache Struts improper action name cleanup

> Attackers can exploit improper action name cleanup in Apache Struts 2, potentially leading to unspecified security impacts.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xm92-v2mq-842q

## What is CVE-2016-4436?

CVE-2016-4436 is a critical vulnerability in Apache Struts, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Struts 2 before 2.3.29 and 2.5.x before 2.5.1 allow attackers to have unspecified impact via vectors related to improper action name clean up.

## Which versions are affected by CVE-2016-4436?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.29 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.29 |
| `org.apache.struts:struts2-core` | Maven | From 2.5-BETA1 | 2.5.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.5-BETA1 | 2.5.1 |

Products: Apache Struts.

## How do I fix CVE-2016-4436?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.29 or 2.5.1.

## Is CVE-2016-4436 being exploited?

There is no known exploitation of CVE-2016-4436 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4436 and fix it if it is affected.

What it is: CVE-2016-4436 is a critical vulnerability in Apache Struts, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4436 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.29
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.29
- org.apache.struts:struts2-core (Maven): affected from 2.5-BETA1; fixed in 2.5.1
- org.apache.struts:struts2-core (Maven): affected from 2.5-BETA1; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4436/ (Markdown: https://insights.sbomify.com/CVE-2016-4436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4436
- OSV: https://osv.dev/vulnerability/CVE-2016-4436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4436/
Summaries are generated and may contain mistakes; the official description above is the record.
